Database Environment Outage
Incident Report for Shipvine
Resolved
The service has remained stable for the past 30 minutes, and we don't find any discrepancies in synchronization data. We apologize for the inconvenience.
Posted Apr 03, 2024 - 22:10 EDT
Monitoring
Database connectivity has been stable for the past 10 minutes. We are reviewing sync logs and orders, but it appears that our logic to catch missed syncs and prevent duplicate orders has worked correctly. We're continuing to verify data integrity.
Posted Apr 03, 2024 - 21:48 EDT
Identified
The hosting provider has clarified that the outage has effected networking infrastructure used by the database service, and the underlying issue is still ongoing. Established connections to the databases (which are cached and reused by various Shipvine services) function, but new connections may fail, resulting in intermittent availability. They are aware of the issue and working to resolve it. As a result, you may continue to receive intermittent errors from Shipvine systems until the underlying network issue is resolved. While Shipvine Sync will resolve any backlog of documents, you may wish to avoid interacting with Shipvine systems until the underlying networking issue is resolved.
Posted Apr 03, 2024 - 20:09 EDT
Monitoring
A power failure within the data center caused the database to failover. No data was lost and the system has resumed normal operation after about 15 minutes of downtime.
Posted Apr 03, 2024 - 19:52 EDT
Investigating
Our hosting provider is reporting an availability issue with the database that hosts Shipvine Logistics. Other systems are available but are unable to communicate with Shipvine Logistics. We are continuing to investigate.
Posted Apr 03, 2024 - 19:28 EDT
This incident affected: Accounts, Bills, Labels, Logistics, and Sync.