Shopify Webhook Delays
Incident Report for Shipvine
Resolved
Shopify has marked the incident as resolved.
Posted Feb 23, 2022 - 19:02 EST
Monitoring
Due to an error on Shopify's end, some webhooks have been delayed, which would have caused a delay of several hours between pressing "Request fulfillment" in Shopify and the order appearing as a fulfillment request in Shipvine. The "webhook" is when Shopify notifies Shipvine that there is an order to pick up for fulfillment.

Older Shopify integrations, where you do not seen a blue "In progress" bar on the Shopify fulfillment, work on a polling model and were not effected by this issue. You can see the status at https://www.shopifystatus.com/incidents though they have a tendency to delete the incident upon resolving the issue.

We've been seeing a marked increase in out-of-order webhook notifications from Shopify since 5 p.m. Eastern, suggesting that they are indeed resolving the issue. We can't detect any rhyme or reason to which webhooks were delayed, so merchants on the Shopify V2 integration may notice that some fulfillment requests appeared in the system 4-6 hours after initially requesting fulfillment from within Shopify.

Again, the nature of the error was that Shopify did not notify Shipvine of some orders for some merchants in a timely manner, and now they are appearing in the system as Shopify is clearing the backlog. Shipvine's systems were operating normally during this period.
Posted Feb 23, 2022 - 17:30 EST
This incident affected: Logistics and Sync.